System Requirements

Accessing all Smartly courses requires a working internet connection. In addition, for the best experience, we recommend that you update to the latest stable release of your operating system and browser. Note that Smartly does not actively block access to any unsupported versions of browsers and operating systems, but we cannot guarantee stability and performance if the minimum thresholds below are unmet.

Browsers and Operating Systems

Microsoft Windows 7+
  • Chrome 51+, latest stable recommended
  • Firefox 49+, latest stable recommended
  • Internet Explorer 10+, Edge or Chrome recommended
  • Edge 31+, latest stable recommended
Mac OS X 10.9+
  • Chrome 51+, latest stable recommended
  • Firefox 49+, latest stable recommended
  • Safari 9+, latest stable recommended
iOS 9+ 
  • Mobile Safari
Android 4.4+
  • Chrome for Android 51+, latest stable recommended
  • Note: we do not support the legacy Android browser
Linux (beta)
  • Ubuntu 16.04+
  • Fedora 25+
  • Red Hat Enterprise Linux 7+
  • Chrome 51+, latest stable recommended

Bandwidth

Desktop

  • Broadband service; minimum 300 kbps up/down, 5 Mbps+ recommended

Mobile

  • 4G+ connection required, LTE recommended

3rd Party Software Requirements

Slack

  • Students who are accepted into the MBA and Executive MBA degree programs will be required to use Slack for exercises and collaboration. Slack system requirements can be found here.

Excel

  • While not required, students who are accepted into the MBA and Executive MBA degree programs are recommended to have access to Microsoft Excel 2016. Students without access to this software may substitute Google Sheets or an older version of Excel. Microsoft Office system requirements can be found here.

Still need help? Contact Us Contact Us